
StackingNxG 
Welcome to StackingNxG, the state of the art 2D and 3D stacking diagram creator.  StackingNxG 
easily allows you to create high quality Color Coded 2D Stacking Diagrams, 3D Stacking 
Diagrams and Floor Plans.   
 
You should continue to explore the help files to learn all about the many powerful and easy to use 
features of StackingNxG. 
  

 
 

PlanData's Space Documentation Services 

Most companies use PlanData's space documentation services in order to get a "head start" in 
documenting their properties. These services range from converting existing CAD files into 
SpaceMan, producing CAD files for your company, field measuring properties (using high tech 
laser measuring devices), or documenting the tenant partitioning within space to help in the 
leasing effort. 

If you would like more information on these services, please contact PlanData at 1.800.757.BLDG 
or visit us on our Web Site, www.PlanData.com. 

 



Technical Support Options 

If you need further assistance, please contact us at: 

 

PlanData Systems Corp. 

11 Stewart Ave. / Suite 200 

Huntington, NY 11743 

 

Phone:   1-800-757-BLDG 

Fax:    631-427-9490 

E-mail:   support@PlanData.com 

Website: Http://www.PlanData.com 

 

Introduction to StackingNxG 

StackingNxG integrates space-related data to floor plans so that you can produce graphic 
representations of the data in an easy-to-use and cost-effective way.   The end result is that you 
are no longer dependent on computer specialists to produce sophisticated graphics of space-
related data, such as color-coded floor plans 

 

Installation and Program Requirements 

StackingNxG is a Windows based application program and will run on Microsoft Windows 
98/NT/2000/XP 

 

The minimum requirements for running StackingNxG are: 

 Pentium III Processor 

 128 MB of RAM required (256 MB recommended) 

 Up to 50 MB of hard disk space for installation 

 

Due to the fact that StackingNxG is a graphic application, the more power that your computer has 
the better.  Almost equally important is the availability of RAM. 

 

To Install StackingNxG: 
Place the CD in your CD-ROM drive.  Select "Install SpaceMan." (SpaceMan will automatically 
install StackingNxG) 



Follow the prompts of the installation program. 
  
StackingNxG requires a User ID along with a password.  Your system administrator can set up 
your access.  See also Defining User Privileges/Administrative Rights 

 

Color Coding 

Color Code Plan allows you to view a color-coded floor plan which can be very helpful when 
trying to get a handle on all the data associated with a space.  You may color-code any of the 
data that resides on the database of your floor plans. For example, you can color code for Area 
Types, Available Space, Income, Lease Expiration, and Options based on data that has already 
been entered into the database.  On retail properties, this list is usually much more extensive and 
includes sales performance data, etc. 

 

Each type is assigned a range by default.  The default settings may be changed for a realistic 
allocation that your company uses. 

To produce a color-coded floor plan: 
 Spaces on the floor plan must be assigned before using this feature.  See Assigning New Space. 

Select Graphics > ColorCode or click on the Tricolored  PlanData logo icon. 
Select a category type, then click on the Ok button. 

The drawing will color code and a legend will be created on the right hand side of the screen.  

 

To print the color-coded floor plan:  

Keep in mind that a color-coded floor plan only prints in default view, not a selected window. 

1. Select File > Print or click on the print icon. 

2. Send the drawing to the printer. 

3. Click on the Print icon . 

 

Select the Clear Color-Code icon to return to command mode and remove color-coding. 

 

Reports on Project 

Go to Reports > View Reports.   A project is usually all the plans in one building. 



 

Report Tab:  select the type of report that you want and its destination, either to Window or 
Printer.  More than one report can be selected at once - select All to print all reports in a project. 

 

 

Selection Tab:  Click on this tab to choose which building, floor, and unit you would like the 
report to describe.  Make sure that the highlight bar is on the desired report when setting the 
selection criteria. 

 



 

Setup Tab:  Choose this tab to enter headers and footers for the report.  Data entered in blue is 
user-definable and changes will be made to the system.  Data in black is not changeable as it 
reflects information already in the database.  The report name is predefined for each report.   

 

Open Drawing 

Allows the user to select a SpaceMan database, Building to Stack and Initial Color Code to open. 
 

 
 

SpaceMan Database - Selecting SpaceMan project to be opened 

Building to Stack - In the SpaceMan Database, you can select the building you wish to view 

Color Code - Based on the data in the database, gives the ability to do an Initial Color Code 

 

Save As 

Allows the user to save the current drawing. 

Mostly used on Floor Plans, this utility will allow a user to save the current drawing as either a 



VDI, VDF, DWG, or DXF file.  The VDI and VDF are Vector Draw file formats, while DWG and 
DXF are AutoCad file formats. 

 

Copy Screen Image to Clipboard 

This command, located on the File menu, allows you to copy the graphic image to the clipboard 
for use in any Windows program that allows cut and paste functionality. 

 

Zoom to the area you want to copy and select File > Export > Copy Screen Image to 
Clipboard. Everything that is visible in the window floor plan area will be copied to the clipboard. 
You can switch to another application (e.g. MS Word, Excel, etc.) and copy image into the 
document in that application. Generally, you will be able to do this by selecting Edit > Paste or by 
pressing Ctrl-C in that application. 

Your selection will remain on the clipboard until you replace it by copying another. 

 

Create Image File 

Allows the user to create an image of the current floor plan or stacking diagram. 

The save options are save as .bmp, .jpg, or .png 

1. Go to File - Export 

2. Select Create Image File 

3. Save Image File to place of users choosing 

 

 

 

Send Email 

Allows the user to send an email of the floor plan or stacking diagram 

Send Email - It will create a PNG (Portable Network Graphic) of currently viewed floor plan or 
stacking diagram into the users default email client.  The user then just has to set a To: email 
address and any comments and will be able to send the drawing using the default email client. 

Please note when the Email client is opened 

 A. The To: box will be blank 

 B. The Subject will be: Floor Plan/Stacking diagram 

 C. The attached file will be named based on the floor code of your building and will be a 
PNG file. 

 



Print Setup 

Allows the user to modify the printer, paper size and orientation of the drawing 

 

Printer - Change the Printer to any printer that is installed on the local computer 

Paper - Modify the size and source of the paper to be used 

Orientation - Modify the drawing to print either in Portrait or Landscape 

 
 

Print 

Allows for the printing of Floor Plans, 2D Stacking Diagrams and 3D Stacking Diagrams 



 

Print allows you to print out your floor plans and stacking diagrams.  It allows the modification of 
the Plot Margins, Paper Orientation, Scale, Color and Print Area of your Floor Plans and 
diagrams 

 

General 

Gives the ability to modify the Font, Font Size, Font Style, as well as the VDI Save Version and 
Cad Save Version.  It also allows the ability to load the last stack diagram opened. 

 



 

 

Font - Ability to modify the Font, Font Size, and Font Style 

 

VDI Save Version - When saving to VDI, this is the version it is saved as 

 

Cad Save Version - When saving to Cad, this is the version it is saved as  

 

StartUp - Ability to open the last opened Stack Diagram on Start up. 

 

Stack 2D 

Gives the ability to modify the Floor Alignment, Floor Height, and Room Display of the 2D 
Stacking diagram 



 

Floor Alignment - This command will modify the 2D stacking diagram's Floor Alignment. Also 
see..Stack Alignment 

Room Display -  This command will modify the 2D stacking diagram's Room Display.  Also see.. 
Stack Unit Width 

Floor Height - This command will modify the 2D stacking diagram's Floor Height,  Also see.. 
Stack Floor Height 

 

Stack 3D 

Gives the ability to modify the 3D view of the stacking diagram as well as the turn on and off the 
viewing of labels. 



 
 
Vertical Scale Factor - Specifies the overall Vertical Scale Factor applied to properties that 
specify sizes, distances, or offsets  

Current 3D View - Displays the current X and Z axis of the 3D View, this would have to been 
modified using the 3D Dynamic View 

Default 3D View - Displays the default X and Y axis of the 3D View 

View Labels - Allows the user to turn on and off labels in the 3D stacking diagram.  For this to 
work, you must close and reopen yourproject. 

 

Close 

This command will close StackingNxG. 

 

Zoom In 

There are many different ways to view a drawing in StackingNxG using zoom.  The commands 
can be accessed by going to View or by selecting the corresponding icon, if given, on the main 
toolbar. 

 

    Zoom In -  The zoom in command is used to enlarge the center of your screen 
by 50 percent. This command reduces the scope of the area that you are viewing so that you can 
see a detailed portion of your floor plan. 



 

Zoom Out 

There are many different ways to view a drawing in StackingNxG using zoom.  The commands 
can be accessed by going to View or by selecting the corresponding icon, if given, on the main 
toolbar. 

 

   Zoom Out - The zoom out command reduces the screen by 50 percent. Use the 
zoom out tool to extend the field of vision on a floor plan.  

 

Zoom Previous 

There are many different ways to view a drawing in StackingNxG using zoom.  The commands 
can be accessed by going to View or by selecting the corresponding icon, if given, on the main 
toolbar. 

 

.  Zoom Previous - Restores the previous zoom setting. 

 

Zoom Window 

There are many different ways to view a drawing in StackingNxG using zoom.  The commands 
can be accessed by going to View or by selecting the corresponding icon, if given, on the main 
toolbar. 

 

  Zoom Window - Allows you to zoom in on a specific portion of the screen. 

   1. Click on the  Zoom Window Icon. 

   2. Click while positioning the cursor on the corner of the area that 
you wish to enlarge. 

   3. Drag the cursor diagonally to the opposite corner of your 
selection. You will see a box expanding around the area of your selection. When you capture the 
area, click again. StackingNxG will redraw the screen, showing only the area that you captured 
for view.  

 

To return to the original view, click on the  default view icon. 

 



Zoom Default View 

There are many different ways to view a drawing in StackingNxG using zoom.  The commands 
can be accessed by going to View or by selecting the corresponding icon, if given, on the main 
toolbar. 

 

  Zoom Default View - Usually, as part of our initial services, PlanData has set the default 
view in order for you to maximize your view of the entire floor plan based on the unique geometry 
of every building.  Please note that when a floor plan is open the first time, the default view of the 
floor plan is displayed. 

 

3D Dynamic View 

With dynamic viewing, you can display the effects of changing your viewpoint as you view 
temporary changes. You can display parallel and perspective views from any angle and distance.  
You can Change the 3D Dynamic View with your pointing device.  By default, StackingNxG sets a 
camera point at the center of the drawing. 

 

To Enable 3D View 

1. Go to View - 3D View  

 

Restore 3D View 

To Restore the Default view 

1. From the View Menu, choose Restore 3D view 

This will restore the project to its original condition  

 

Pan 

You can shift the location of your view by using Pan.  You can Pan Dynamically by moving your 
pointing device. Pan does not change the location or magnification of objects on your drawing; it 
changes only the view. 

 

To Enable Pan 

1. Go to View - Pan or click on the  Pan icon. 

 



Redraw Screen 

This command is used to redraw your current screen without changing the current view. You may 
notice that sometimes your drawing contains small lines or marks left over from deletions. If you 
redraw the screen, these marks will disappear. To redraw your screen select View > Redraw 

Screen from the menu bar or Click on the Redraw icon . 

 

Stack Alignment 

This command allows for the transformation of the 2D stack. 

Stack Alignment - Left - This command will modify the 2D stacking diagram so that the diagram 
will be left justified 

Stack Alignment - Center - This command will modify the 2D stacking diagram so that the 
diagram will be center justified 

Stack Alignment - Right - This command will modify the 2D stacking diagram so that the 
diagram will be right justified 

Stack Alignment - Justify - This command will modify the 2D stacking diagram so that the 
diagram will be justified on both the right and left. 

 

Stack Floor Height 

This command allows for the transformation of the 2D stack. 

 

Stack Floor Height - Fit All - This command will modify the 2D stacking diagrams floor height of 
each building floor so that the stacking diagram will fit in the displayed window 

Stack Floor Height - Set Height - This command will modify the 2D stacking diagrams floor 
height to be equal to the size entered with this command.   

 

Stack Unit Width 

This command allows for the transformation of the 2D stack. 

Stack Unit Width - Proportional - This command will modify the 2D stacking diagrams area of 
each assigned space to be proportional to the area listed. 

 For example..  There are  two spaces assigned  

 A. 1000 SF Rentable Area 

 B. 4000 SF Rentable Area 

Space B will look 4 times as large as Space A in the Stacking Diagram when it is set to 
Proportional 



Stack Unit Width - Equal - This command will modify the 2D stacking diagrams view of the all 
assigned spaces to be equal with one another regardless of size. 

 For example..  There are  two spaces assigned  

 A. 1000 SF Rentable Area 

 B. 4000 SF Rentable Area 

Space B will look exactly the same as Space A in the Stacking Diagram when it is set to Equal 

Stack Unit Width - Set Minimum - This command will modify the 2D stacking diagrams 
minimum size for all areas assigned space to be at a minimum size. 

 For example..  There are  two spaces assigned  

 A. 25 SF Rentable Area 

 B. 4000 SF Rentable Area 

 C. Minimum set for 200 

Bases on the data presented, if there was no minimum width for a space, it would be impossible 
to be able to view the text in Space A, but if the minimum is set, viewing the text is now possible. 

       

 

Layer Manager 

Allows you to see different combinations of layers found in the CAD & StackingNxG files 

You use the Layer Manager command to: 

 1. Display or hide individual layers, ranges of layers, or all layers on the screen. 

 2. Restore initial displayed/hidden state of the layers 

This command is used to control which information in the reference file (CAD) is displayed. To 
turn a reference layer on or off, select View > Layer Manager from the menu bar or click on the 

 Layer Manager icon. 

The Layer Manager box will appear on your screen. Check the On Column for the layers that you 
want to see, and uncheck it for those you do not want to see.  Click Apply if you want to see the 
changes in the display without leaving Layer Manager, and OK if you want to apply changes and 
close Layer Manager.  



 

 

Color Code 

Select Graphics > Color-Code or click on the Tricolored  PlanData logo icon. 

Select a category type, then click on the Ok button. 

The drawing will color code and a legend will be created on the right hand side of the screen. 



 

Please note that the color codes that are listed are based on what has been previously setup in 
the SpaceMan database file. 

 

 

Clear Color Code 

Select the Clear Color Code icon to remove color-coding and the legend. 

 

View Reports 

This menu item will allow the user to view and print out reports. 

Go to Reports > Report on Current Drawing.  This selection will give you a report on whichever 
drawing you are working with.  You can select all the reports, a few, or just one and the printed 



report will reflect your choices.  A screen will appear with three tabs. 

The Report Tab: 
Click on the tab titled Report to select the type of the report that you want and its destination, 
either to Window or Printer  Notice that you can select one or more reports to print at once, by 
clicking on the box next to them or selecting All. 

The Selection Tab: 
Only the building/floor associated with the current drawing will be a choice. 

Note: Make sure that the highlight bar is on the desired report when setting the selection criteria. 
The Setup Tab: 
Choose this tab to enter headers and footers for the report.  Information in black cannot be 
altered by the user, while the data in blue is user-definable.  However, the changes will not be 
permanently entered into the system.  Once you close the drawing and reopen it, the changes 
you made previously will not be there. 

 

Measure Distance 
This menu item will calculate the linear footage of a given line. 

To Measure Distance: 
1. Select Utilities > Measure Distance 

2. Click on two points for a calculation of the linear footage 
3. Right click to end selection, and view the linear footage.  

4. When finished click OK to clear the dialogue box from the screen. 

 

Show Dimensions 
This menu item will turn on and off the dimensions on the floor plan. 

To Show Dimensions 

1. Select Utilities > Show Dimension 

 

Help About 

Details the version of the software that is currently in use. 

 



 

 

Open a Drawing 

Allows the user to select a SpaceMan database, Building to Stack and Initial Color Code to open. 

 

1. Select File - Open Drawing 

2. Select the Open Drawing Icon  
 

 
 

SpaceMan Database - Selecting SpaceMan project to be opened 

Building to Stack - In the SpaceMan Database, you can select the building you wish to view 

Color Code - Based on the data in the database, gives the ability to do an Initial Color Code 

 

Use this Image in another Program 

If you want to use the color coded image in another program, such as Microsoft Word, the two 
easiest ways to do this is by either saving the image to the clipboard and cut and pasting into 
Word, or saving the image to a image file and inserting the picture into Word. 

 

Create Image File 

1. Go to File - Export 

2. Select Create Image File 

3. Save Image File to place of users choosing 

 



Copy Screen Image to Clipboard 

Zoom to the area you want to copy and select File > Export > Copy Screen Image to 
Clipboard. Everything that is visible in the window floor plan area will be copied to the clipboard. 

 

Send a Floor Plan or Stacking Diagram 

Allows the user to send an e-mail of the floor plan or stacking diagram 

 

Send Email - It will create a PNG (Portable Network Graphic) of currently viewed floor plan or 
stacking diagram into the users default e-mail client.  The user then just has to set a To: Email 
address and any comments and will be able to send the drawing using the default email client. 

 

Please note when the Email client is opened 

 A. The To: box will be blank 

 B. The Subject will be: Floor Plan/Stacking diagram 

 C. The attached file will be named based on the floor code of your building and will be a 
PNG file. 

 

1. Go to File - Send Email 

 

Print a Floor Plan or Stacking Diagram 

Allows for the printing of Floor Plans, 2D Stacking Diagrams and 3D Stacking Diagrams 



 

Print allows you to print out your floor plans and stacking diagrams.  It allows the modification of 
the Plot Margins, Paper Orientation, Scale, Color and Print Area of your Floor Plans and 
diagrams 

 

1. Go to File - Print or the Print Icon  

2. After setting all options, select Print 

 

Move Around the Drawing 

There are many different ways to view a drawing in StackingNxG.  The two most common are 
Zoom and Pan.   

Zoom allows you to use the mouse to zoom in and out of a drawing using the Scroll Wheel on the 
mouse if you have one, also by holding down the Scroll Wheel, you can Pan through the drawing.  
If the user does not have a mouse, the zoom functions are available by selecting View - Zoom In, 
View - Zoom Out, View - Zoom - Previous, Zoom Window or by selecting View - Pan, when the 
user has completed using Pan, by right clicking on the mouse, the Pan Icon will disappear.  

 

The Zoom functions are 

 Zoom In  



 Zoom Out 

 Zoom Previous 

 Zoom Window 

 

View Data 

The biggest benefit of StackingNxG is the ability to view data for the Floor Plans and Stacking 
Diagrams.  Viewing this data could not be easier.  To view data, right click on a space to get the 
menu. 

 

When you right click on a space, in either the Stacking diagrams or floorplan, it will give you the 
option of viewing your data.  In this example, the data available to view is Building Information, 
Room Area Data, Base Lease Information, Option Information and Prospect Data.  When a Data 
item does not have a red check mark, then it does not have any data for that item.  In the 
previous example you will notice that Prospect Data for this space has no data. 

 

View and Modify Assignments 

To view Assignments, right click on a space that you wish to see data for. 

 

1. Right Click on Space 

2. Select Assignments 

3. Select Modify this Room to modify the room you have selected 

4. Select Modify All on Floor to modify all assignments on the floor 

5. In 3D Stack, you can select Modify All Rooms Within Building to modify all assignments within 
the building 



The options available are 

 A. Hide Assignment 

 B. Resize Assignment 

 C. Rotate Assignment 

 D. Change Assignment to any available Assignment 

 

Changing Color Codes 

Select Graphics > Color-Code or click on the Tricolored  PlanData logo icon. 

Select a category type, then click on the Ok button. 

The drawing will color code and a legend will be created on the right hand side of the screen. 

 

Please note that the color codes that are listed are based on what has been previously setup in 
the SpaceMan database file. 



 

 

Viewing Reports 

Go to Reports > Report on Current Drawing.  This selection will give you a report on whichever 
drawing you are working with.  You can select all the reports, a few, or just one and the printed 
report will reflect your choices.  A screen will appear with three tabs. 

The Report Tab: 
Click on the tab titled Report to select the type of the report that you want and its destination, 
either to Window or Printer Notice that you can select one or more reports to print at once, by 
clicking on the box next to them or selecting All. 

The Selection Tab: 
Only the building/floor associated with the current drawing will be a choice. 

Note: Make sure that the highlight bar is on the desired report when setting the selection criteria. 



The Setup Tab: 
Choose this tab to enter headers and footers for the report.  Information in black cannot be 
altered by the user, while the data in blue is user-definable.  However, the changes will not be 
permanently entered into the system.  Once you close the drawing and reopen it, the changes 
you made previously will not be there. 

 

Turn off Layers 

Allows you to see different combinations of layers found in the CAD & StackingNxG files 

You use the Layer Manager command to: 

 1. Display or hide individual layers, ranges of layers, or all layers on the screen. 

 2. Restore initial displayed/hidden state of the layers 

This command is used to control which information in the reference file (CAD) is displayed. To 
turn a reference layer on or off, select View > Layer Manager from the menu bar or click on the 

 Layer Manager icon. 

The Layer Manager box will appear on your screen. Check the On Column for the layers that you 
want to see, and uncheck it for those you do not want to see.  Click Apply if you want to see the 
changes in the display without leaving Layer Manager, and OK if you want to apply changes and 
close Layer Manager.  

 

SpaceMan/WebNxG 

SpaceMan/WebNxG is the internet version of StackingNxG.  It has the same functions as 
StackingNxG.   



 

 

Differences between SpaceMan/WebNxG and StackingNxG 

This section details the differences between the two and how to operate SpaceMan/WebNxG.   

 

Logon - SpaceMan/WebNxG uses a registration process from the Internet for logon credentials.  
Once you register at Http://www.plandata.com, your logon information is emailed.  StackingNxG 
logon information is issued by your SpaceMan or StackingNxG administrator. 

Navigation - SpaceMan/WebNxG, instead of tabs, uses the buttons from the startup change to 
select 3D stacking, 2D stacking, or Floor Plans as the start mode.  It also allows you to select 
from drop down menus the Project, Building, Floor, ColorCode, and Start Mode.  You may go to a 
Floor Plan from a Stacking Diagram, but you cannot go to a Stacking Diagram from a Floor Plan.  
You must go back to the start page to select the Stacking Diagrams.  StackingNxG as previously 
stated, uses tabs to select the Stacking Diagrams and Floor Plans.   

Pie Charts - SpaceMan/WebNxG, from the Start Page, allows you to Color Code Pie Charts.  
These can be based on the Building or Project.  

 

 


